[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[IDD #ZHD-705806]: idd.unidata ids feed



Hi Waldenio,

re:
> I have 2 machines for external data exchange: mopora and moingobe.
> 
> Mopora receives data from idd.unidata
> Moingobe receives data from idd.cise-nsf

OK.  I thought that was how things were setup.  In my search yesterday,
I did not see any mopora connections on any of our idd.unidata.ucar.edu
cluster nodes.  I looked again today, and I found what is likely the
cause of some problems:

- we had put in a definition for 'ldm.cptec.br' in our /etc/hosts file

The reason we did this (some time ago) was the DNS for mopora was not
reliable.  This was causing logs of log file entries, and denial of
service for feed requests due to lack of forward and reverse name lookup.
After verifying forward and reverse name lookup for mopora.cptec.inpe.br,
I commented out the ldm.cptec.br entry in /etc/hosts on all of our cluster
nodes so that connections will once again report mopora as the requesting 
machine.

> When idd.cise was down and idd.unidata stops to send data to Mopora, I
> redirected the Mopora feed to Portugal. When idd.cise came back I
> returned Mopora to idd.unidata.

OK.

> I have some problems with Mopora's logfiles. They are being solved, but
> I still dont have these logs.

No worries.

re: I see three CPTEC machines in the ldmd.log file on one or our 
idd.unidata.ucar.edu
cluster nodes:

> > sucuri.cptec.inpe.br - 150.163.147.63
> > cambui.cptec.inpe.br - 150.163.140.42
> > surubim.cptec.inpe.br - 150.163.147.62
> >
re: Are any of these machines known as 
tigge-ldm.cptec.inpe.br/mopora.cptec.inpe.br?

> No, these 3 machines are a internal processing cluster. They should get
> data only from Mopora and Moingobe, nothing else.

The log messages I see about these machines are strange:

logs/ldmd.log.11:Jul  1 17:39:12 uni4 cambui.cptec.inpe.br[22935] NOTE: 
Connection from client LDM silent for 720 seconds 
...
logs/ldmd.log.11:Jul  1 17:43:57 uni4 sucuri.cptec.inpe.br[23340] NOTE: 
Connection from client LDM silent for 720 seconds 

I will ask Steve Emmerson about these tomorrow (he is not in today).

In the process of troubleshooting the IDS|DDPLUS feed to mopora, I decided to 
upgrade
the LDM to the latest "beta" release, ldm-6.7.0.3.  Upgrading make restarting 
the
LDM on the node that had connections from ldm.inpe.br (which I now know was 
mopora)
necessary.  In the past, restarting the LDM would automatically renew feeds to
those (very) few connections that seemed to be active, but were receiving no 
data
(like mopora for IDS|DDPLUS).

Cheers,

Tom
****************************************************************************
Unidata User Support                                    UCAR Unidata Program
(303) 497-8642                                                 P.O. Box 3000
address@hidden                                   Boulder, CO 80307
----------------------------------------------------------------------------
Unidata HomePage                       http://www.unidata.ucar.edu
****************************************************************************


Ticket Details
===================
Ticket ID: ZHD-705806
Department: Support IDD
Priority: Normal
Status: Closed


NOTE: All email exchanges with Unidata User Support are recorded in the Unidata inquiry tracking system and then made publicly available through the web. If you do not want to have your interactions made available in this way, you must let us know in each email you send to us.