Previous: Saving WRF Displays Next: WRF Analysis: Formulas Table of contents Frames User guide
Unidata IDV Workshop for version 5.6 > Accessing and Displaying Data > Working with WRF Output > Interactive

3.13.0.2 WRF Grid Displays
Displays for WRF post-processed data.

The following are examples of some of the different kinds of displays available in the IDV. For more information how to manipulate the display, simply click the image to see the User Guide section for that particular display type. The general format of this section will be an image, followed by the steps needed to reproduce the image. However, before diving into creating different displays in the IDV, let's take a moment to discuss how to handle large data sets.

Preparation: Dealing with Large Data

As you may have experienced, it can take quite some time to get the data into the IDV and render the displays. One way to speed this up is to spatially subset the data over an area of interest. For our case, the Gulf of Mexico is where the 'action' is, so let's subest for that particular region:

  1. Clear any existing data sources and displays by clicking the scissors symbol found just below the Main Menu bar on either the Dashboard to Main View window.

Reload your WRF output using the following steps:

  1. From the Data Choosers tab in the Dashboard, locate your WRF output in the file browser and select the files you wish to load (hold shift to select multiple files)
  2. Make sure that Data Source Type is set to Aggregate Grids by Time
  3. Click Add Source
  4. In the Field Selector panel, right-click your WRF output under Data Sources and click Properties.
  5. From the Properties box, select the Spatial Subset tab and use your mouse to click-and-drag a rectangular box on the Bounding Box map display.
  6. After selecting your spatial subset region, click OK.

Note: Even with spatial subsetting in place, some displays (particularly the three dimensional ones) will take quite some time to render — consider using only one time step when producing these views.

Many of the example images used below take advantage of the NASA blue marble background image. If you wish to use blue marble, simply click Displays→Maps and Bounds→Add Background Image and select Blue Marble. A second way to add the blue marble background is to click the globe icon found just below the Main Menu Bar. Both of these methods can be used from either the Dashboard or the Main Window.

It may seem like we've done a lot of work to setup our environment (loading data, subsetting, adding a background, etc.). To aid in quickly restoring our environment, we will use the bundle feature of the IDV. A bundle is a way of saving the state of the IDV (current data sources, loaded maps, etc.). You can create a bundle that points to local or remote data (an .xidv), or you can create a bundle that actually contains the data (a .zidv), the latter of which is useful when sharing displays of data you've generated yourself, as it ensures your colleagues have the data needed to view the display. For our purposes, let's create a bundle that points to the WRF output on our memory stick:

  1. From the main menu bar, select File→Save As to bring up the Save dialog box.
  2. Make sure Views, Displays, and Data Sources are checked.
  3. Make sure the File Format: is set to IDV Bundles (*.xidv), and name the bundle basicSetup.xidv.
  4. Save your bundle in the same directory as the WRF output on the memory stick

To test the bundle, click the scissors symbol, found just below the main menu bar, to clear out all of the data and displays. Then:

Plan Views

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab. Select Temperature @ Surface and the Color-Shaded Plan View display, then click the Create Display button.
  4. In the Displays panel, Select Temperature @ Surface, and click Edit→Properties, then select the Color Scale Tab and check the box next to visible. Other properties of the color scale can be accessed from this tab, such as position and font properties. Click OK to apply the changes.
  5. Return to the Field Selector panel, expand the 2D grid tab, select Pressure_reduced_to_MSL @ msl and the Contour Plan View display, then click the Create Display button.
  6. In the Displays panel, select the Pressure_reduced_to_MSL field. Click the Change box next to Contour to change the contour properties, such as base contour, interval, and label properties.
  7. In the Displays panel, change the contour color to black by clicking the box next to Color Table (likely labeled PressureMSL) and selecting Solid→Black.
  8. Animate your display by clicking the "play" button, located just above and to the right of your display on the Main View Window.
Wind Barb and Vector Displays

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab. Scroll down and expand the Derived tab. Select the True Wind Vectors field and the Wind Barb Plan View display, and then click the Create Display button.

The initial display of the wind barbs will be quite crowded, so we will need to clean things up a bit.

Note that you can also change from a Wind Barb view to a Streamline view from the display tabs by clicking the button next to Show: Streamlines. Also, if you would rather see a vector plot (as opposed to a barb plot), simply select Vector Plan View, rather than Wind Barb Plan View, from the Field Selector when creating the display.

Trajectory Display

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab. Select Pressure Reduced to MSL @ msl field and the Contour Plan View display, and then click the Create Display button. This will allow us beter select an area of interest for the trajectory display.
  4. In the Field Selector panel, expand the 3D grid tab. Scroll down and expand the Derived tab. Select the Grid 3D Trajectory field and the Trajectory Colored By Parameter display, and then click the Create Display button.
  5. In the Field Selector box that appears, expand the 2D grid tab. Find your WRF data and expand this list. Scroll down and expand the 3D grid and select the Specific humidity and then click the OK button.
  6. The Dashboard window will come to the front of your display and show you the Trajectory Controls. Select 950 as the Level (initial level of the trajectories), select Rectangle for the Trajectory Initial Area, and set the Initial Area Skip Factor to 5.
  7. Return to the Main View window and click-and-drag to set the rectangular area of interest using the rubber-band widget. If you make a mistake, return to the Trajectory Controls on the Dashboard and click the scissors icon.
  8. Once you've selected the initial area for your trajectories, return to the Trajectory Controls in the Dashboard window and click Create Trajectory.
  9. In the Displays panel, select Speficif_humidity_isob.. Click Edit→Properties, select the Color Scale Tab and check the box next to visible. Click OK to apply the changes.
Hovmöller Diagrams

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab. Select Pressure Reduced to MSL @ msl.

In order to clearly see the Hurricane path, we will subset the dataset before we create the Hovmöller diagram.

  1. After selecting Pressure Reduced to MSL @ msl, click the Region tab located in the bottom right panel, uncheck Use Default and select the region of interest by using your mouse to click and drag a rectangular selection on the map.
  2. Selet the Hovmoller→Time-Latitude (Color Shaded) display, then click the Create Display button.
  3. In the Displays panel, select the view for the Hovmöller diagram. Then, from inside the Displays tab, click View→Undock from Dashboard to view the diagram in its own window.

The Time-Latitude Hovmöller display shows Pressure Reduced to Mean Sea-Level as a function of time and latitude. Because we chose Time-Latitude (Color Shaded), mean sea-level pressure will be averaged over longitude for each time-step. To average over latitude instead, recreate the display using Time-Longitude (Color Shaded) display.

Isosurfaces

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 3D grid tab. Scroll down and expand the Derived tab. Select the Speed (from u_wind & v_wind) field and the 3D Surface→Isosurface Colored by another parameter display, and then click the Create Display button.
  4. A pop-up box will prompt you to select which parameter you would like to color the wind speed isosurface. Select 3D grid→Temperature @ isobaric.
  5. In the Displays panel, set the Isosuface value to 20 m/s.
  6. In the Main View window under the Legend List (right edge of the window), right-click the color table and select Edit Color Table. This will bring up the color table editor.
  7. From the editor window, place your cursor over the color table and right click. Select Invert Color Table, and then click OK to exit the editor.
  8. In the Displays panel, Select windspeed - Isosurface, click Edit→Properties, then select the Color Scale Tab and check the box next to visible.

Parameter over Topography

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab and select the Temperature @ surface field and the 3D Surface→Color-Filled Contoured Parameter Over Topography display.
  4. A Field Selector dialog box will appear and ask you to select the Topography field. From your WRF output, select the 2D grid tab and select the Geopotential_height @ surface field and click OK.
  5. Right click the color scale in the legend (right panel in the Main View Window) and change the color scale by selecting Basic→Bright38.
  6. Again, right click the color scale in the legend (right panel in the Main View Window), but this time select Change Range...
  7. Click the Use Predefined box, select From All Data, and then click OK.
  8. In the Displays panel, select Temperature_surface -.... Click Edit→Properties, select the Color Scale Tab and check the box next to visible. Click OK to apply the changes.
Parameter as Topography

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 3D grid tab. Scroll down and expand the Derived tab. Select the Relative Vorticity (from u_wind & v_wind) field and the 3D Surface→Color-Filled Contoured Parameter as Topography display.
  4. Select the "Level" tab from the subset panel and select 500 hPa, and then click the Create Display button.
  5. Right click the color scale in the legend (right panel in the Main View Window) and change the color scale by selecting Basic→Bright38.
  6. Again, right click the color scale in the legend (right panel in the Main View Window), but this time select Change Range...
  7. Click the Use Predefined box, select From All Data, and then click OK.
  8. In the Displays panel, select relvort - Color-Filled.... Click Edit→Properties, select the Color Scale Tab and check the box next to visible. Click OK to apply the changes.
Cross Sections

The image above is created from velocity data. A 2D color shaded plan view of speed at 2 m AGL is displayed along with two cross sections — one of wind speed and the other of horizontal wind vectors. Both cross sections are set to coincide, though this is not the default behavior. To produce the cross sections shown above, do the following:

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab. Scroll down and expand the Derived tab. Select the Speed (from u_wind & v_wind) field and the Cross sections→Color-Shaded Plan View display, and then click the Create Display button.
  4. Return to the Field Selector panel, expand the 3D grid tab. Scroll down and expand the Derived tab. Select the Speed (from u_wind & v_wind) field and the Cross sections→Color-Filled Contour Cross Section display, and then click the Create Display button.
  5. Return to the Field Selector panel, expand the 3D grid tab. Scroll down and expand the Derived tab. Select the True Wind Vectors (from u_wind & v_wind) field and the Flow Displays→Vector Cross Section, and then click the Create Display button.

Notice that at this point, each cross section has its own control in the view window. To link the cross sections such that they coincide, do the following:

  1. In the Display panel, select windspeed - Color-Filled Contour Cross Section, then click Edit→Sharing→Sharing on.
  2. Repeat the above step for the truewindvectors - Vector Cross Section display.
  3. Use your mouse to move one of the cross section indicators in the Main View Window to 'snap' the two separate cross sections together.

Now that the two cross sections are linked, let's clean up the vector plot as it's pretty cluttered:

  1. In the Displays panel, select truewindvectors under View1, and click the Settings tab.
  2. Change the color of the barbs to white by selecting "white" from the dropdown box next to Color.
  3. Reduce the number of vectors being plotted by clicking Edit→Properties, select the Spatial Subset tab in the Properties box that appears, and set X Stride: and Y Stride: to Every twentieth point.

As a final step, make sure the color scale used in both speed displays (plan view and cross section) have the same range, and display one of the scales. For each color scale in the legend (right panel in the Main View Window):

  1. Right click the color scale in the legend (right panel in the Main View Window), select Change Range...
  2. Click the Use Predefined box, select From All Data, and then click OK.

Then, add the color scale to the display:

  1. In the Displays panel, select either windspeed - listed under View1, and set the Settings tab.
  2. Click Edit→Properties, select the Color Scale Tab and check the box next to visible. Click OK to apply the changes.
2D and 3D Data Probes

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 2D grid tab and select the Pressure_Reduced_to_MSL @ msl field. Then, hold control (or Command, if on a Mac) and select the Plan Views→Contour Plan View and Data Probe/Time Series displays, and then click the Create Display button.

In the Main View Window, you will see contours of Pressure_Reduced_to_MSL @ msl, as well as a Probe marker (in the example above, the marker is a yellow rectangle located just NW of Cuba). You can click and drag the probe marker to move it to a location of your choice. The corresponding time series plot will show up in the Dashboard under the Display tab (shown above the Main View Window in our example image). Note that the Data Probe will also work with three-dimensional data, and you will be able to move it vertically as well.

Time-Height Display

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 3D grid tab, and select the Relative Humidity @ isobaric field. Then, hold control (or Command, if on a Mac) and select the 3D Surface→Isosurface and Probes→Time/Height Display (Contours) displays, and then click the Create Display button.
  4. In the Display panel, select Relative_humidity - Isosurface, and set the isosurface value to 90%.

In the Main View Window, you will see the 90% RH isosurface, as well as a time-height marker (in the example above, the marker is red vertical line with a rectangle on top). You can click and drag the probe to move it to a location of your choice.

Skew-T Displays

  1. Clear any existing displays by clicking the red and white eraser symbol found just below the Main Menu bar on either the Dashboard to Main View window.
  2. Make sure your WRF ouput is loaded (or utilize the bundle we just created).
  3. In the Field Selector panel, expand the 3D grid tab. Scroll down and expand the Derived tab. Select the Sounding Data (with true winds) field and the Soundings -> Grid Skew-T.
  4. Before creating the display, look below the display panel for the subset panel and select the Times tab. Select Use Selected from the drop-down box and select the first three time steps (hold control or command to select multiple times),then click the Create Display button.
  5. Next, select the Region tab and click-and-drag a rectangular region around Cuba - we're subsetting spatially to focus on the hurricane.
  6. Add a Color-Shaded Plan View of the 2D variable Pressure_reduced_to_MSL @ msl to more easily navigate the skew-T location marker through the dataset (similar to the time-height marker from the previous example).
  7. Place the skew-T location marker in a region of interest and return to the Dashboard Displays tab. Undock the display (View→Undock from Dashboard).

A feature of the skew-T display is that you can animate skew-T's in time. However, sometimes it is nice to see consecutive skew-T's (data from two different times) on the same chart. Underneath the Skew-T diagram are the display controls, which includes the ability to see Consecutive Profiles (simply check the box next to Consecutive Profiles to enable this feature). To update the sounding parameters, use the middle click on your mouse to set the location of the originating parcel. If you are using a Mac Trackpad, you will need to select a point on the skew-T diagram with Command+Click, then use Option+Click to update the parameters.

 


Previous: Saving WRF Displays Next: WRF Analysis: Formulas Table of contents Frames User guide
Unidata IDV Workshop for version 5.6 > Accessing and Displaying Data > Working with WRF Output > Interactive