Re: is Visad compatible with J2SE 1.5?


Hi Sofyan,

Forgive me if you have already done this, but did you reinstall Java3D *after* your J2SE 1.5 upgrade?

When I upgraded from Java 1.4.x to 1.5, I ended up


1) uninstalling J2SE 1.4.x and my current Java3D
2) installing J2SE 1.5
3) installing Java3D
4) recompiling VisAD

This last step probably isn't nescessary, especially since I needed to tell the Makefile to compile with 1.4.

Hope this helps.

-kevin.


Kurnianto, Sofyan (CIFOR) wrote:

Hi colleagues,

I am using Visad to show the 3-D map. When I used J2SE 1.4.2, it works. But when I am trying to update my java to J2SE 1.5, there is error message and the 3-D map is not showing. The message is:

Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: sun/awt/DrawingSurface

at javax.media.j3d.DrawingSurfaceObjectDSI.getDrawingSurfaceObjectInfo(DrawingSurfaceObjectDSI.java:72)

at javax.media.j3d.Canvas3D.paint(Canvas3D.java:1242)

Are there any suggestions to solve this problem? For information I’m using Java 3D 1.3.

Sofyan Kurnianto

Center for International Forestry Reseacrh (CIFOR)

Jl. CIFOR, Situ Gede, Sindang Barang

Bogor Barat 16680, Indonesia

www.cifor.org <http://www.cifor.org/>


--
+------------------------------------------------------------+
Kevin L. Manross        [KD5MYD] <><          (405)-366-0557
CIMMS Research Associate               kevin.manross@xxxxxxxx
[NSSL-WRDD/SWATN]           http://www.cimms.ou.edu/~kmanross

"My opinions are my own and not representative of CIMMS, NSSL,
NOAA or any affiliates"
+------------------------------------------------------------+