Re: DODS netCDF server / VisAD netCDF form

Well, it turns out that the taaba.nc DDS URL works fine in
Netscape, but prints out an error message in Internet Explorer.

Since all that matters is that my data is accessible via DODS
within my Java applications, I don't care if IE doesn't work.

What I don't understand is how a browser can impact CGI on the
server side.....

-Curtis

At 04:46 PM 11/25/2002, you wrote:
>Hello,
>
>I am just getting started with DODS. I have set up a DODS server
>and put up a dataset for testing. I'm running into problems when
>I try to grab the data's DDS as follows:
>
>   http://eftemcam.microscopy.wisc.edu/cgi-bin/dods/nph-dods/dods/taaba.nc.dds
>
>The weird thing is, the following HTML URL works fine:
>
>   http://eftemcam.microscopy.wisc.edu/cgi-bin/dods/nph-dods/dods/taaba.nc.html
>
>Also, if you download the dataset directly from:
>
>   http://eftemcam.microscopy.wisc.edu/dods/taaba.nc
>
>then it works just fine from the VisAD SpreadSheet.
>
>I put up another test dataset ("images.nc" that's part of the
>VisAD examples), and both of the following work fine:
>
>   
> http://eftemcam.microscopy.wisc.edu/cgi-bin/dods/nph-dods/dods/images.nc.html
>   http://eftemcam.microscopy.wisc.edu/cgi-bin/dods/nph-dods/dods/images.nc.dds
>
>The taaba.nc file was generated with VisAD's netCDF file form.
>Thus, this looks to be a bug with either the VisAD netCDF form
>or the DODS netCDF server. Anybody know what's going on?
>
>Thanks,
>Curtis
>
>P.S. I did one more test, rewriting images.nc with the netCDF
>file form to "img-test.nc" and it also works fine. So if it's
>a bug in the netCDF form, it only happens sometimes.