Re: Border Panel

Does your HTML for the applet include an "archive" attribute that
includes the visad.jar file?  e.g.,

<applet archive="mycode.jar,visad.jar" code="myapplet.class" width=500
height=500></applet>

The CLASSPATH that you set in the autoexec.bat (or in other environment
variables) will not matter to the browser.  You either have to put the
visad.jar file into the browser's directory-of-jar-files, or use the
archive attribute.

In all your postings, it would be very helpful to include any short code
snippets related to what you're doing.

tom

On Fri, 4 Jan 2002, Yakup Bayram wrote:

> I was using symentec.itools.awt Border Panel. Now, I am using swing jpanel.
> It is ok. It works.
> I have another problem. When I run my software for only simple frame case,
> it works. When I added a simple applet and execute in Web Browser, it gives
> the following error:
>
> java.lang.NoClassDefFoundError: visad/Unit
>
>  at JFrame1.<init>(JFrame1.java:25)
>
>  at JApplet1.init(JApplet1.java:26)
>
>  at sun.applet.AppletPanel.run(Unknown Source)
>
>  at java.lang.Thread.run(Unknown Source)
>
> My internet explorer is set to Java 2 v.1.3.1_02 for applets.
> In the autoexec.bat file I set class path for Visad.jar and it works in
> Visual Cafe' Xe 4 however, in web browser It doesn't see the visad.jar.
> Yakup.
> ----- Original Message -----
> From: "Tom Whittaker" <tomw@xxxxxxxxxxxxx>
> To: "Yakup Bayram" <ybayram@xxxxxxxx>
> Cc: <visad-list@xxxxxxxxxxxxx>
> Sent: Friday, January 04, 2002 6:39 AM
> Subject: Re: Border Panel
>
>
> > I don't think there is a class BorderPanel in the main Java swing
> > library (at least I could not find it).  Where did you get the
> > "BorderPanel"?  What does it do?
> >
> > tom
> >
> > On Thu, 3 Jan 2002, Yakup Bayram wrote:
> > > Hello,
> > > I am trying to add the 3D object to Borderpanel instead of  showing in a
> frame. What I do is, first I create a frame and place a border panel in it
> then I add the 3D object in to borderpanel. There is no compiler error, it
> shows panel but there is no object on it. When I try to show the object on
> frame it works, but on borderpanel it doesn;t,
> > > Best Regards,
> > >
> >
> > --
> > Tom Whittaker
> > University of Wisconsin-Madison
> > Space Science and Eng. Center
> > ph:  608.262.2759
> >
> >
>
>

--
Tom Whittaker
University of Wisconsin-Madison
Space Science and Eng. Center
ph:  608.262.2759