[thredds] WMS GetFeatureInfo and text/xml format

Hi all!
We're running a TDS version 4.14 at http://mandeo.meteogalicia.es/thredds/ with WMS enabled for most datasets. Everything seems to work fine but the request GetFeatureInfo with INFO_FORMAT=text/xml that returns a 404 server error. Oddly enough it works fine with INFO_FORMAT=image/png.
Here are two sample requests:
- image/png:
http://mandeo.meteogalicia.es/thredds/wms/modelos/WRF/diario/20100713/wrf_arw_det_20100713_04km_00Z_0d.nc?LAYERS=temp&TRANSPARENT=true&PROJECTION=EPSG%3A4326&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_xml&FORMAT=image%2Fpng&CRS=EPSG%3A4326&BBOX=-13.223999%2C40.099609%2C-2.776001%2C45.900391&I=403&J=271&INFO_FORMAT=image%2Fpng&QUERY_LAYERS=temp&WIDTH=951&HEIGHT=528 <http://mandeo.meteogalicia.es/thredds/wms/modelos/WRF/diario/20100713/wrf_arw_det_20100713_04km_00Z_0d.nc?LAYERS=temp&TRANSPARENT=true&PROJECTION=EPSG%3A4326&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_xml&FORMAT=image%2Fpng&CRS=EPSG%3A4326&BBOX=-13.223999%2C40.099609%2C-2.776001%2C45.900391&I=403&J=271&INFO_FORMAT=image%2Fpng&QUERY_LAYERS=temp&WIDTH=951&HEIGHT=528>
- text/xml:
http://mandeo.meteogalicia.es/thredds/wms/modelos/WRF/diario/20100713/wrf_arw_det_20100713_04km_00Z_0d.nc?LAYERS=temp&TRANSPARENT=true&PROJECTION=EPSG%3A4326&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_xml&FORMAT=image%2Fpng&CRS=EPSG%3A4326&BBOX=-13.223999%2C40.099609%2C-2.776001%2C45.900391&I=403&J=271&INFO_FORMAT=text%2Fxml&QUERY_LAYERS=temp&WIDTH=951&HEIGHT=528 <http://mandeo.meteogalicia.es/thredds/wms/modelos/WRF/diario/20100713/wrf_arw_det_20100713_04km_00Z_0d.nc?LAYERS=temp&TRANSPARENT=true&PROJECTION=EPSG%3A4326&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_xml&FORMAT=image%2Fpng&CRS=EPSG%3A4326&BBOX=-13.223999%2C40.099609%2C-2.776001%2C45.900391&I=403&J=271&INFO_FORMAT=text%2Fxml&QUERY_LAYERS=temp&WIDTH=951&HEIGHT=528> And I think it happens the same with the Unidata THREDDS server (at least for the couple datasets I checked):
-image/png:
http://motherlode.ucar.edu:8080/thredds/wms/fmrc/NCEP/NAM/Alaska_11km/files/NAM_Alaska_11km_20100713_1200.grib2?service=WMS&version=1.3.0&request=GetFeatureInfo&CRS=EPSG:4326&BBOX=-173.00808315884012,29.942938114140194,-62.65376446200439,70.07676781418297&FORMAT=image/png&width=500&height=500&query_layers=Dew_point_temperature&layers=Dew_point_temperature&styles=&TIME=2010-07-13T12:00:00.000Z/2010-07-14T00:00:00.000Z&info_format=image/png&I=231&J=66
-text/xml:
http://motherlode.ucar.edu:8080/thredds/wms/fmrc/NCEP/NAM/Alaska_11km/files/NAM_Alaska_11km_20100713_1200.grib2?service=WMS&version=1.3.0&request=GetFeatureInfo&CRS=EPSG:4326&BBOX=-173.00808315884012,29.942938114140194,-62.65376446200439,70.07676781418297&FORMAT=image/png&width=500&height=500&query_layers=Dew_point_temperature&layers=Dew_point_temperature&styles=&TIME=2010-07-13T12:00:00.000Z/2010-07-14T00:00:00.000Z&info_format=text/xml&I=231&J=66
Any idea what's wrong here?
Thanks.


Cheers!!