Re: [netcdf-hdf] netcdf-beta-4/HDF5 build problem with H5Adelete

Andrew Porter <a.r.porter@xxxxxxxxxx> writes:

> Hello,
>
> I'm attempting to build NetCDF version beta 4.0 including support for 
> HDF5 using version 1.8.0 beta 4. My system is running an up-to-date 
> installation of FedoraCore 7, the gcc and g95 compilers and has open MPI 
> installed.

Howdy!

It's a bit confusing to work with two packages, but there is no beta4
of netCDF 4.0. There has only been one netCDF-4 beta release.

The HDF5-1.8.0-beta4 release contains many changes and a few known
issues. Until the issues are resolved it will not work with netCDF-4.

To build netCDF-4, get the netCDF-4 snapshot release here:
http://www.unidata.ucar.edu/software/netcdf/builds/snapshot/netcdf-4/

Also get the HDF5 release on that page (which is a pre-beta4 snapshot
of HDF5 which works with netCDF-4). Then build according to the
instructions here:
http://www.unidata.ucar.edu/software/netcdf/netcdf-4/newdocs/netcdf-install/Quick-Instructions.html

The HDF5 team have already been notified of the issues in beta4, and
they will be issuing a beta5 release sometime in the next few weeks to
correct them. At that time, netCDF-4 will be tested with their beta
release.

Thanks!

Ed
-- 
Ed Hartnett  -- ed@xxxxxxxxxxxxxxxx